My E28 535is Turbo Buildup Thread by Brad D.

By stevegolf
( 2 )

My E28 535is Turbo Buildup Thread 


Compliments of Brad D. @ http://www.mye28.com


Well, I decided years ago that I would own a turbo BMW. I never quite wanted to buy a kit ( partly due to the initial cost, partly because I love to do it myself) so I set out on making my own setup. 

The platform is my '87 535is which I have owned since '99. I originally bought a bunch of 745i parts but ended up selling them to help fund my turbo 240sx project. About 2 years ago I installed a m30b35 and all of the associated wiring. Unfortunately Motronic 1.3 does not take well to being turboed. I would later find a solution for this. 

 

Here's another pic of the car (11/'08 ). 

 

With new Spax suspension 12/'08 

 

While all of my fabrication isn't quite complete I wanted to start a buildup thread to outline my work so far and add to it as I go. 

I have boxes of parts and pretty much everything I need to make it happen has been purchased. Everything else I have made. 

I fabricated my own manifold adapter out of weld-els. 

 

The center tube is for my 38mm Tial WG. The stock manifold will be flipped and have been gasket matched to the head. You can sorta see the WG mounted during mockup. 

 

 

Turbo has a GT40 compressor wheel in a .50AR housing. Turbine is a T4 P-Trim wheel in a .84AR Euro T4 housing (has a T3 footprint). 

 

Function 7 oil flanges and -4AN oil feed line. 

 

Installed 

 

I decided that I wanted to run a front mount IC. While it is possible and fits very nicely behind the factory IS airdam, major valance trimming is required. 

 

 

IC piping installed. 

 

 

 

Thats where I am currently. I have a box full of 3" mandrel bends to build my downpipe and a new exhaust with a Magnaflow muffler and cat which shoul show up this week. 

As for other items that are of importance I will be running 42lb/hr injectors and have already finished building my MS2 and a Glens Garage idle board. I still need to finish my Motronic adapter harness but that shouldn't take too long to finish. While its got a ways to go I am past the point of no return and am confident that it will be a success and look professional when it is completed. I would love to hear everyones comments and feedback.


10/6/2007

Progress Update - 

Had a little time today to begin working on the downpipe. Its 2.5" out of the turbo transitioning into 3" all the way back. I'm pretty proud of it. I still need to add the wastegate return but now that its where it is, that should be easy. Tomorrow I should finish it up back to the cat flange and get the wastegate dump plumbed in. 

 

 

 

 

Here is how the wastegate mounts. The dump will be straight shot right into the downpipe (don't mind the coil wire). 


10/14/2007

Well, I made more progress this weekend, but I didn't take any pics. I'll get around to getting some soon though as everything is coming together nicely. I got my turbo oil drain in the oil pan drilled and tapped. I got the wastegate dump plumbed into the downpipe. I also fabbed up an inlet pipe with a fitting for the bosch bypass valve I will be using. I also plumbed the IACV back into the IC piping so I can have idle control. Its down to all the little nitty gritty details now. I still need to drill my oil filter block for my oil feed, fab up my exhaust, heat wrap stuff, paint things, install MS and add a few wiring circuits. No sweat! 8)


10/21/2007

Update time! I didn't have a whole lot of time today to get much done but I knocked out a few odds and ends and took some pics. 

Engine bay shot 

 

Air filter and BPV fittings. I have an upgraded billet bosch BPV replacement. (thank you Volvo) 

 

Oil return installed. 

 

All stainless Swagelok oil return. 

 

Oil feed in filter housing installed 

 

Wastegate dump pipe 

 

 

I've still got lots to do. Hopefully I will get some more done tomorrow. I will take more pics as usual.


10/27/2007

Exhaust is done! 3" Mandrel bends with a Magnaflow cat and muffler. Tip is just some cleaned up 3" SS tubing TIG'd on. 

 

 

Downpipe closeup 

 

Manifolds and WG dump 

 

I wanted the valve cover and intake to look decent as they were orignally dirty and covered in cosmoline. I went for the not so original but clean wrinkle black with shaved raised lettering. It looks even better in person. 

 

 

I should get the downpipe wrapped tomorrow so I can reinstall all of the exhooassed parts and the turbo with all new gaskets as well as get the intake and valve cover reinstalled after I do a valve adjustment.


10/31/2007

Manifolds installed, turbo bolted in with the DEI turbine blanket and downpipe all wrapped up. I should have all of the exhaust bolted in tonight. It's coming together now! 


11/4/2007

Well, I got more done this weekend. Had fun putting in new parts. The exhaust is installed and looks great. I've almost wrapped up everything under the hood. Only a few clamps here and there, a little wiring and some extra heat wrap on the exhaust side. 

Intake and BPV installed. 

 

Wastegate installed. You can also see the oil return line mounted up. 

 

Custom catch can I made up - its baffled inside and is packed with stainless coily cleaning pads. It has a drain on the bottom. Now I just need to make a mount for it. 

 

Megasquirt and my adapter box. It has the Glen's Garage idle board inside it. The pink wire is for my WB o2 input. 

 

 

Injectors are in and all of the IC piping back on. 

Only the pipe and the connector were from a Volvo (740 turbo IIRC). I have a giant box of hoses, pipes, brackets and random crap I have collected over the years. I have the valve from the Volvo somewhere and it probably would have worked but it was kind of large.The BPV im using is a new billet aluminum Bosch replacement.


12/31/2007

A few little update pics: 

Gauge pod install. I think I am going to swap out the water temp for oil pressure, I just had the temp gauge when my stock gauge stopped working but its all good now. For now though it will work. 

 

Updated engine bay pics from this evening. Still need to do a bit of cleaning though and add the rest of my thermal wrap on the wiring harness now that all of the MS stuff is working. 

 

The car is running and driving however, my cheapo laptop died so I haven't been able to drive the car since last week. Fortunately today I was able to borrow a laptop for a while so I should be able to get some more tuning done this weekend. Closed loop idle is nice and I have some of the low kPa/low rpm map sorted out. Megalogviewer is awesome!


12/23/2007

The manifold adapter was made out of Sch40 1.5"ID mild steel weld-els. 

 

The actual collector were just weld els carefully cut and the wastegate was added after it was completed but torching out a hole. 

 

Here is another angle of the completed adapter. 


1/9/2008

A little update - after acquiring another laptop for tuning I have been plagued with a major misfire issue that basically makes the car undriveable. As of tonight I figured out what the problem was. For anyone who cares or for future reference for those building their own MS2/extra setup. 

The problem - 

I have been getting severe ignition breakup and replaced my coil. Well, it seems as though that was not the issue. I am beginning to think it is something internal to MS itself. I am running a 330ohm pull up resistor on the ignition driver, dwell is set at 2.1 sec.The car starts and idles great but if revved up to any rpm and allowed to sit there it begins to break up and misfires terribly, even revving the engine with no load. While this is occuring the VB921 is getting extremely hot (~130F). If allowed to return to idle and cool off, it will idle fine but any constant rpm or significant load and it repeats the misfire all over. I am not sure if it is a hardware problem on the board(incorrect pull up ckt, bad vb921, etc), or something else. I should also note that my tach, driven off JS11 has gotten very jumpy also. 

Also, can a vb921 be dying, but still run the car at idle? 

The solution - 

I think have solved my problem and I do feel like somewhat of a doofus. I wired my ignition driver as per the MS2 manual here in the internal board wiring section, only I used a 330ohm resistor. However, I seemed to have missed one seemingly critical piece of information - D14 needs to be set as spark output A in Megatune if using this ignition configuration. I had mine set to js10 and removed its jumper and once switched to D14 all of my issues have seemingly gone away. Also, the vb921 stays cool to the touch during operation with no ignition breakup at all. I haven't driven the car around other than in and out of the garage, but I could not reproduce the symptoms that I have been having just free revving in the driveway. I really do hope this is the end of one problem so I can get on with the whole process of actually tuning the car!


1/16/2008

Well, I actually got to drive the car for about an hour tonight and I have the <90kpa region reasonably sorted out. The car runs very well and is super smooth with the exception of acceleration enrichment which is currently "disabled" for early tuning purposes. I forayed into a bit of boost and saw about 5 psi by 3200rpm with only 50% throttle and it felt great. I have my AFRs in this region around 12.3:1 which is good. I haven't even gone to WOT so I can't imagine how fast this thing is going to be when it is totally sorted. I am so excited now that I am past the initial gremlins which caused me so much grief. It feels good to finally drive my creation. 


2/26/2008

Man, the car runs great and the wastegate spring holds a solid 5psi all the way to redline. AFR is a nice 12.2:1 under boost. The car feels so much faster, easily faster than the e28 m5s I have driven. I have been made a believer in the turbo big six - it's so much fun. However, I did have a bit of a setback. When I first got the car running I thaught I head the occasional thumping from a dying center bearing. Well, all the boost didn't help and I promptly finished it off. Here is a little sampling of the destruction. 

 

Once I had that sorted out it was time for more boost. I then kept blowing off IC piping so I decided to bead roll all of my piping. No more popped hoses. I think this turbo is going to systematically find all of the cars shortcomings and make them glaringly obvious, but this typically leads to cool upgrades so I'm not complaining. 8)


9/26/2008

Just thought I'd throw up a little update on the car. About a month ago I upgraded my brakes to the 540i F/R setup. The stock brakes were in desperate need of replacing and just weren't up to the task of slowing down the car with all the new power. Front calipers were reman TRW units and the rears were used pulled off of a 740il. They were painted with Duplicolor caliper spray paint. I also addes a set of Speedbleeders. These are highly recommended! I upgraded to SS lines all around. Pads are Centric Posi-Quiet semi-mets (for those that don't know, Centric is owned by Stoptech) Rotors are drilled and slotted units from R1 Concepts. Very nice pieces, maybe not quite Brembo quality but nice nonetheless. They have a nice anti rust coating and over a month later not a lick of rust in site on the hat or vanes. 

All I can say is that I am amazed by the performance of the brakes. Initial bite is fantastic and the pedal has a nice firm feel. Modulation is now much easier. I feel that the SS lines also contribute and are a great upgrade, even to a stock system. Overall stopping power is excellent, but I have no quantitative testing to report. The Centric pads are very nice and are very low dusting. The dust they do make is more of a silvery grey and is less noticealbe than "black" dust. I will give some more long term feedback on them as time passes. 

 

 

 

The next upgrade was to the suspension. Having ridden in LJ's (Nebraska_e28) car with Spax springs and Bilstein sports, I knew that was the setup I wanted to go with. The ride is very firm but composed and easy to live with on a daily basis. I replaced the front swaybar endlinks and reinforced the sway bar mounting tabs on the strut tubes to prevent them from failing when I upgrade bars. I also repalced the rear dogbones. The car now handles the way I feel it should. It's more fitting to the rest of the performance of the car. I only have some pics of the components but will be getting so fresh full body shots of the car, hopefully this weekend. 

 

 

Here are the plates I made to weld to the strut tube. 

 

And here is current engine bay shot for good measure. 


10/11/2008

Recently I had become curious what my car would sound like without a cat so I set out to remove it and replace it with a test pipe. Removal was no where as easy as I had anticipated it would be. I made the mistake of not flanging the connection and using u-bolt style clamps which cut into the metal and almost "swage" the two pieces of pipe together. This makes it hard to pull the pipes apart. I ended up having to cut a notch into the cat with a die grinder to get it off. 

When I eneded up getting it out of the car I was greeted with a cat that sounded like a maraca. The brick is pretty much wasted being blown apart and melted. This is with about 8 months of driving and tuning. It definitely did not hold up well and had to have been costing be power. Looking through the matrix with a light shows a good portion of what was left is clogged. I cut a section of tubing to replace the cat and clamped it in place with Dynaflex Truseal clamps which are awesome. I haven't driven the car far yet with it out but the exhaust note is almost unchanged at idle but sounds so much raspier and has much more character than it did with the cat under load. 

 

 

It's much worse even that it looks in the pics as it is has crumbled inside the matrix and it is hard to get it to show up in a pic.

Well, I can say that after having driven the car today without a cat it sounds a little throatier under load but definitely not loud. It doesn't even come close to loud like a Tri-Flow on an NA car. Boost builds a few hundred rpm earlier and I would be willing to bet that post turbine EGTs are also down (I don't monitor them). It also feels like it revs much freer now.


12/7/2008

Dyno results here.


5/20/2009

Tonight I finished my heat shield for my intake. I wanted to prevent the intake from ingesting hot, underhood air so I fabbed up a nice little heat shield from some sheet metal and sprayed it with plastidip and trimmed it with some vacuum tubing. It looks pretty decent. I have some insulation I may add to the outside of the box, but I'll see how this does. I have some new stainless hardware to replace the crusty bolts on the compressor cover, I just didn't get around to it. 

 

 


09/21/2009 

Update: 

It's been a while since I have updated this thread even though I have done a fair amount of work to the car. I just thought I would compile some of my mods here for future reference in this thread. I just completed my wasted spark install which was highly successful and a very worthwhile mod. A few months ago I added Homelink to the car so I can get rid of all of the openers that were scattered around my car. I also updated the two gauge dash pod I had to a three gauge pod, but I don't have any good pics of this mod yet. 

Some upcoming mods include poly UCABs and poly subframe bushings for Ireland Engineering. I will also be modifying the rear subframe so that camber and toe are adjustable.


11/28/2009

Today I installed my S3.25 that I found at the local PnP. The fluid that was in it was super clean and the magnet had almost no accumulation on it. I also replaced all of the half shaft bolts. It was filled with M1 75W-90 LS synth gear oil. It went in very smoothly and took about an hour. 

Impressions: 

For reference I am changing out my S3.73 that I was running. 

I am going to get a speeding ticket. I am used to cruising at almost 3000rpm at 70mph, and now I am under 2500rpm. It just doesn't "sound" or feel like I'm going as fast as a I am. 

First gear is usable again. Second gear pulls almost as hard as before but is much more usable. It still has massive wheelspin, but since you get more time in gear, I think it is actually faster. Third is awesome and it feels like it just wants to pull forever. Cruising is must nicer too as it's like I actually have an overdrive gear again. 

I can't wait to get my new Clutchmasters clutch from Todd so I can turn the boost up and see what I can get out of this turbo and injectors. This diff will suit more power very nicely and is a huge improvement over the short 3.73.


12/1/2009

I have another observation that is worth noting. The diff loads the engine differently and spools the turbo much sooner. In 4th gear, almost 500 rpm sooner. In 5th it's almost 800rpm sooner. This has led to me having to retune a portion of my fuel map as there was never any boost in that area before. It's definitely a problem I can deal with.


12/2/2009

Well, I got a little bit of tuning done tonight on the way home. The lower boost onset region is finished and I am almost tuned to 11psi (was at 8.5). It definitely feels a lot better now and the turbo is really coming alive and it feels like it complements the diff nicely. It should be dry out tomorrow ( I found the rev limiter a couple of times) and I'll try to get it fully tuned at 11-12 psi. The amazing part is that the clutch hasn't flared yet, but if it does, I don't really care.


12/3/2009

The car is now fully tuned to 12psi, and it feels great. It feels really fast and pulls awesome on the freeway. The turbo is really starting to come into its efficiency island and hit very hard. The diff is definitely a welcome addition at this boost level. It still spins in second, but not as violently which means better acceleration. And the amazing thing.....the clutch is holding.... 

It held a full pull to redline through 4th. I lifted at 6100 as I was running out of real estate and that was right about 130 indicated. It scoots. I can't imagine this thing at 17psi.


12/6/2009

I would like to point out that I am able to run 0.030" gap with no spark blowout at 12psi running a MSD wasted spark setup. I know there have been people who have reported blowout at boost lower than this at this gap running the stock ignition system. Now I just need to track down a spare flywheel so I can have it machined so I can just install it when I do my clutch install.


4/13/2010

 My lazy butt (more like way too busy) still hasn't done the clutch yet but have been daily driving the car at 12 psi. I am almost at 80%DC on the 42lbers at 6400rpm. I am totally comfortable running them to over 90% which means I have a bit of headroom left in them. I could also raise the fuel pressure to gain a bit more flow. For now though they are supplying enough fuel to keep the party fun.


1/3/2013

Wow, I haven't seen this thread in a while. A quick update which isn't very exciting - the car is running well at 12psi and has been since this thread was updated. It's crazy to think that the last post in this thread was 2010. Time flies when you are having fun.

I did finally put the clutch in last summer. It has been great. Pedal feel is basically like stock and engagement isn't touchy at all. All in all I would highly recommend that clutch for anyone wanting great driveability with good holding power.